solydx-system-adjustments-9 problem

Post your bugs here.
User avatar
ilu
Posts: 1877
Joined: 09 Oct 2013 12:45

solydx-system-adjustments-9 problem

Postby ilu » 12 Dec 2017 14:00

Since installing the point release updates yesterday I'm having problems with packagekit. It exited with an error message about not being able to something with triggers for solydx-system-adjustments-9 ... It seemed to have installed nothing, but calling apt afterwards showed no problems. Now today it refuses to update anything with the message: "Error while installing package: subprocess installed post-installation script returned error exit status 1". In fact it installed everything just not the problematic package.
(Packagekit output is really a mess. Really, schoeljes updatemanager was so much better . .. )

Anyway:

Code: Select all

apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  linux-headers-liquorix-amd64 linux-image-liquorix-amd64 thunderbird thunderbird-solydxk-adjustments
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

dpkg --list | grep -ve 'ii\|^rc'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                       Version                           Architecture Description
+++-==========================================-============================
iF  solydx-system-adjustments-9                2.9.1                             all          Adjustments specific to SolydX (version 9, stretch).
hi  thunderbird                                1:52.4.0                          amd64        The Thunderbird e-mail client
hi  thunderbird-solydxk-adjustments            2017.09.02                        all          Thunderbird adjustments for SolydXK

sudo dpkg --configure -a
Setting up solydx-system-adjustments-9 (2.9.1) ...
update-initramfs: deferring update (trigger activated)
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-4.12.0-14.3-liquorix-amd64
Found initrd image: /boot/initrd.img-4.12.0-14.3-liquorix-amd64
Found linux image: /boot/vmlinuz-4.9.0-4-amd64
Found initrd image: /boot/initrd.img-4.9.0-4-amd64
Found linux image: /boot/vmlinuz-4.9.0-3-amd64
Found initrd image: /boot/initrd.img-4.9.0-3-amd64
Found Microsoft Windows XP Professional on /dev/sda1
Found Windows 7 on /dev/sdc1
Found SolydX 8 64-bit (8) on /dev/sdc2
done
Removing 'diversion of /usr/share/xfce4/backdrops/xfce/xfce-teal.jpg to /usr/share/xfce4/backdrops/xfce/xfce-teal.jpg.divert by solydx-system-adjustments-9'
Removing 'diversion of /usr/share/xfce4/backdrops/xfce/xfce-blue.jpg to /usr/share/xfce4/backdrops/xfce/xfce-blue.jpg.divert by solydx-system-adjustments-9'
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.12.0-14.3-liquorix-amd64
W: Possible missing firmware /lib/firmware/radeon/banks_k_2_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_mc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_asd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_sos.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_mec2.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_mec.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_me.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_pfp.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_ce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_mec2.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_mec.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_me.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_pfp.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_ce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_sdma.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_sdma.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_vce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_vce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris11_k_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris10_k_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/banks_k_2_smc.bin for module radeon

apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  linux-headers-liquorix-amd64 linux-image-liquorix-amd64 thunderbird thunderbird-solydxk-adjustments
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Regarding the packages on hold: the liquorix kernel won't install because it needs gcc7 but it has nothing to do with this problem. Thunderbird on hold is ok because I don't want it to update - after every other update I have to reconfigure all my calendars and I'm really fed up with this misbehaviour. (Allthough I don't remember if and where I put it on hold :o but it seems that I managed somehow.) Do thunderbird-solydxk-adjustments need the latest thunderbird version?
Regarding the missing firmware messages: This doesn't look like anything my system would need, but since a few days I'm changing in between radeon and amdgpu for testing purposes, atm it's radeon.
What could be the reason for solydx-system-adjustments-9 refusing to do its postinstall?

User avatar
Arjen Balfoort
Site Admin
Posts: 8642
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: solydx-system-adjustments-9 problem

Postby Arjen Balfoort » 12 Dec 2017 14:35

I haven't been able to duplicate this (installed on 3 systems, including my development system).
What is the output if you reinstall the package?

Code: Select all

apt reinstall solydx-system-adjustments-9
thunderbird-solydxk-adjustments depends on the thunderbird package only (no version number required).


SolydXK needs you!
Development | Testing | Translations

User avatar
ilu
Posts: 1877
Joined: 09 Oct 2013 12:45

Re: solydx-system-adjustments-9 problem

Postby ilu » 12 Dec 2017 16:11

Code: Select all

apt reinstall solydx-system-adjustments-9
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 4 not upgraded.
Need to get 0 B/1989 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 518072 files and directories currently installed.)
Preparing to unpack .../solydx-system-adjustments-9_2.9.1_all.deb ...
Unpacking solydx-system-adjustments-9 (2.9.1) over (2.9.1) ...
Processing triggers for solydxk-system (3.0.4b6) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Setting up solydx-system-adjustments-9 (2.9.1) ...
update-initramfs: deferring update (trigger activated)
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-4.12.0-14.3-liquorix-amd64
Found initrd image: /boot/initrd.img-4.12.0-14.3-liquorix-amd64
Found linux image: /boot/vmlinuz-4.9.0-4-amd64
Found initrd image: /boot/initrd.img-4.9.0-4-amd64
Found linux image: /boot/vmlinuz-4.9.0-3-amd64
Found initrd image: /boot/initrd.img-4.9.0-3-amd64
rmdir: failed to remove '/mnt/a1': Device or resource busy
Found Microsoft Windows XP Professional on /dev/sda1
Found Windows 7 on /dev/sdc1
Found SolydX 8 64-bit (8) on /dev/sdc2
done
Processing triggers for fontconfig (2.11.0-6.7+b1) ...
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.12.0-14.3-liquorix-amd64
W: Possible missing firmware /lib/firmware/radeon/banks_k_2_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_mc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_asd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_sos.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_mec2.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_mec.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_me.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_pfp.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_ce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_rlc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_mec2.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_mec.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_me.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_pfp.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_ce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_sdma.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_sdma.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/vega10_vce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_vce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris12_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris11_k_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/polaris10_k_smc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/banks_k_2_smc.bin for module radeon

User avatar
Arjen Balfoort
Site Admin
Posts: 8642
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: solydx-system-adjustments-9 problem

Postby Arjen Balfoort » 12 Dec 2017 16:54

With one SolydX laptop I found that there was an endless loop between libc-bin and solydxk-system but I couldn't find anything in the output nor the logs what caused it. I simply hit the update button again and it finished without errors.

I guess that this is what caused your problem as well but lead you solydx-system-adjustments-9.


SolydXK needs you!
Development | Testing | Translations

User avatar
ilu
Posts: 1877
Joined: 09 Oct 2013 12:45

Re: solydx-system-adjustments-9 problem

Postby ilu » 12 Dec 2017 17:12

Yes, that sounds like it. Because packagekit was the first one to hit apt and resulted in error - and me manually doing the same solved it yesterday. Now that you mention it I vaguely remember something about a libc. Today an additional manual configure was needed. And packagekit has no logs :evil: , so I could not find what exactly was the problem yesterday.

User avatar
Arjen Balfoort
Site Admin
Posts: 8642
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: solydx-system-adjustments-9 problem

Postby Arjen Balfoort » 12 Dec 2017 17:36

I'll have to create a VM with a 201707 ISO and test with that. I don't know when I have the time to do that, though.


SolydXK needs you!
Development | Testing | Translations

User avatar
ilu
Posts: 1877
Joined: 09 Oct 2013 12:45

Re: solydx-system-adjustments-9 problem

Postby ilu » 12 Dec 2017 18:03

no problem, everything works - it was just weird.

User avatar
Arjen Balfoort
Site Admin
Posts: 8642
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: solydx-system-adjustments-9 problem

Postby Arjen Balfoort » 12 Dec 2017 19:50

Well...that was a waste of time!
I installed the 201707 ISO and ran "gpk-update-viewer --verbose" from terminal and all went fine without problems :shock:


SolydXK needs you!
Development | Testing | Translations


Return to “Bug control”

Who is online

Users browsing this forum: No registered users and 1 guest