Broken dependencies following upgrade

Questions about SolydX and SolydK installation.
abuyahya
Posts: 13
Joined: 30 Nov 2013 14:39

Broken dependencies following upgrade

Postby abuyahya » 24 Dec 2017 03:13

Hey guys.

I have been using Solydk For about 4 years (and linux for about 10years) as i like the rolling release concept. I needed php7 so decided to upgrade.

I upgraded from jesse solyd8 to sketch solyd 9

It upgraded with some errors

I rebooted fine.

but package manger seems to be a bit stuck because of broken dependencies.
The following packages have unmet dependencies:
libkf5screen-bin : Breaks: kscreen (< 4:5.8) but 1.0.2.1-1 is to be installed
libkf5screen7 : Breaks: kscreen (< 4:5.8) but 1.0.2.1-1 is to be installed
N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
any help is greatly appreciated

User avatar
ilu
Posts: 1877
Joined: 09 Oct 2013 12:45

Re: Broken dependencies following upgrade

Postby ilu » 24 Dec 2017 10:13

Please post the terminal output of sudo apt update && sudo apt upgrade -s

abuyahya
Posts: 13
Joined: 30 Nov 2013 14:39

Re: Broken dependencies following upgrade

Postby abuyahya » 24 Dec 2017 13:32

ilu wrote:Please post the terminal output of sudo apt update && sudo apt upgrade -s
lots of packages kept back ?? not upgraded i assume

Code: Select all

Hit http://www.mirrorservice.org solydxk-9 InRelease
Ign http://ftp.uk.debian.org stretch InRelease                               
Get:1 http://ftp.uk.debian.org stretch-backports InRelease [91.8 kB]         
Get:2 http://security.debian.org stretch/updates InRelease [63.0 kB]           
Hit http://ftp.uk.debian.org stretch Release.gpg                                                            
Get:3 http://ftp.uk.debian.org stretch-backports/main amd64 Packages/DiffIndex [27.8 kB]
Hit http://www.mirrorservice.org solydxk-9/main amd64 Packages                              
Get:4 http://ftp.uk.debian.org stretch-backports/contrib amd64 Packages/DiffIndex [6,640 B]     
Get:5 http://ftp.uk.debian.org stretch-backports/non-free amd64 Packages/DiffIndex [5,656 B]                  
Get:6 http://ftp.uk.debian.org stretch-backports/main i386 Packages/DiffIndex [27.8 kB]
Get:7 http://ftp.uk.debian.org stretch-backports/contrib i386 Packages/DiffIndex [7,132 B]
Hit http://www.mirrorservice.org solydxk-9/upstream amd64 Packages              
Hit http://security.debian.org stretch/updates/main amd64 Packages                   
Get:8 http://ftp.uk.debian.org stretch-backports/non-free i386 Packages/DiffIndex [5,656 B]
Hit http://ftp.uk.debian.org stretch Release                                                        
Hit http://security.debian.org stretch/updates/contrib amd64 Packages                       
Hit http://www.mirrorservice.org solydxk-9/import amd64 Packages                                               
Get:9 http://ftp.uk.debian.org stretch-backports/main amd64 2017-12-24-0335.21.pdiff [1,023 B]             
Get:10 http://ftp.uk.debian.org stretch-backports/main amd64 2017-12-24-0335.21.pdiff [1,023 B]
Hit http://www.mirrorservice.org solydxk-9/main i386 Packages                                
Hit http://security.debian.org stretch/updates/non-free amd64 Packages                                          
Get:11 http://ftp.uk.debian.org stretch-backports/main i386 2017-12-24-0335.21.pdiff [1,018 B]                     
Hit http://www.mirrorservice.org solydxk-9/upstream i386 Packages                                            
Get:12 http://ftp.uk.debian.org stretch-backports/main i386 2017-12-24-0335.21.pdiff [1,018 B]
Hit http://ftp.uk.debian.org stretch/main amd64 Packages                                                    
Hit http://www.mirrorservice.org solydxk-9/import i386 Packages                                                
Hit http://security.debian.org stretch/updates/main i386 Packages                                              
Hit http://ftp.uk.debian.org stretch/contrib amd64 Packages                              
Hit http://ftp.uk.debian.org stretch/non-free amd64 Packages   
Hit http://security.debian.org stretch/updates/contrib i386 Packages
Hit http://ftp.uk.debian.org stretch/main i386 Packages
Hit http://ftp.uk.debian.org stretch/contrib i386 Packages
Hit http://security.debian.org stretch/updates/non-free i386 Packages
Hit http://ftp.uk.debian.org stretch/non-free i386 Packages
Fetched 238 kB in 1s (128 kB/s)          
Reading package lists... Done
N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
Reading package lists... Done
Building dependency tree                                                                                                                                                           
Reading state information... Done                                                                                                                                                  
Calculating upgrade... Done                                                                                                                                                        
The following packages have been kept back:
  advancecomp adwaita-icon-theme akonadi-backend-sqlite akonadi-server amarok amarok-common amarok-utils android-tools-adb apache2 apache2-bin apache2-data apache2-utils
  apparmor-utils apt apt-file apt-utils aptitude aptitude-common ark aspell baloo baloo-utils baloo4 bc bind9-host bluedevil bluez bluez-obexd bogofilter-bdb boinc-client
  bonnie++ btrfs-tools build-essential cdrdao chromium cmake cmake-data coinor-libcbc3 coinor-libcgl1 coinor-libclp1 command-not-found conky-all cowsay cpp crda cups
  cups-browsed cups-bsd cups-client cups-core-drivers cups-daemon cups-filters cups-filters-core-drivers cups-ppdc curl dconf-gsettings-backend dconf-service debhelper debugedit
  digikam digikam-data digikam-private-libs dirmngr dmeventd dmsetup dnsmasq-base dolphin dvd+rw-tools eclipse-rcp efibootmgr eject enblend enfuse evince evince-common
  exim4-base exim4-config exim4-daemon-light exiv2 ffmpegthumbnailer file filezilla filezilla-common findutils firmware-linux firmware-linux-nonfree fonts-roboto freerdp-x11 ftp
  g++ gambas3-gb-form gambas3-gb-gtk gambas3-gb-gui gambas3-gb-qt4 gawk gcc gdisk geany geany-common geany-plugin-updatechecker geany-plugins-common geoclue-2.0 ghostscript
  ghostscript-x gimp gimp-data gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gir1.2-packagekitglib-1.0
  gir1.2-vte-2.91 glib-networking glib-networking-common glib-networking-services glx-alternative-mesa glx-diversions gnome-disk-utility gnome-icon-theme gnome-keyring
  gnome-themes-standard gnome-themes-standard-data gnupg gnupg-agent gnupg2 gparted gpgsm gpsd grub-customizer gstreamer1.0-libav gstreamer1.0-plugins-base
  gstreamer1.0-plugins-base:i386 gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x gtk2-engines-pixbuf gtk2-engines-qtcurve gufw
  guile-2.0-libs gvfs gvfs-common gvfs-daemons gvfs-libs gwenview handbrake hardinfo hplip hplip-data hplip-gui htdig hugin hugin-data hugin-tools hunspell i7z-gui icu-devtools
  ifupdown imagemagick imagemagick-6.q16 imagemagick-common initramfs-tools iproute2 iptables iputils-ping isc-dhcp-client isc-dhcp-common jack-capture jackd2 jackd2-firewire
  k3b k3b-data k4dirstat kaddressbook kamera kate kate-data katepart kcalc kcharselect kde-baseapps-bin kde-baseapps-data kde-config-gtk-style kde-runtime kde-style-oxygen
  kde-window-manager kdeconnect kdelibs-bin kdelibs5-data kdelibs5-plugins kdenetwork-filesharing kdepasswd kdepim-runtime kdepimlibs-kio-plugins kdesudo kdf kdoctools kfind
  kget kgpg khelpcenter4 kinfocenter kio-audiocd kio-mtp kipi-plugins kipi-plugins-common kmenuedit kmod knotes kodi kodi-bin kodi-data konqueror-nsplugins konsole kopete kppp
  krdc krusader ksaneplugin kscreen ksh ksnapshot ksysguard ksysguardd ksystemlog ktorrent ktorrent-data kuser kvkbd kwalletmanager kwrite libaacs0 libabw-0.1-1
  libakonadi-calendar4 libakonadi-contact4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4 libakonadi-notes4 libakonadiprotocolinternals1 libalgorithm-diff-xs-perl
  libandroidsdk-ddmlib-java libapparmor-perl libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-pkg-perl libarchive-extract-perl libarchive13 libaspell-dev libaspell15
  libasprintf-dev libastro1 libatomic1 libaudiofile1 libavcodec57 libavfilter6 libavformat57 libbaloocore4 libbaloofiles4 libbaloopim4 libbalooqueryparser4 libbalooxapian4
  libbit-vector-perl libboinc7 libc-bin libc-dev-bin libc6 libc6:i386 libc6-dev libcairo-perl libcairo2 libcairo2:i386 libcalendarsupport4 libcdr-0.1-1 libchromaprint1
  libcilkrts5 libclass-c3-xs-perl libcln6 libclone-perl libcloog-isl4 libcloog-ppl1 libcommon-sense-perl libcpan-meta-perl libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl
  libcryptsetup4 libcups2 libcups2:i386 libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libcurl3-gnutls libcurl4-openssl-dev libdate-calc-perl libdate-calc-xs-perl
  libdbd-mysql-perl libdbi-perl libdconf1 libdevmapper-event1.02.1 libdevmapper1.02.1 libdjvulibre21 libdrm-dev libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2
  libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libe-book-0.1-1 libeasymock-java libegl1-mesa libegl1-mesa:i386 libenchant1c2a libepub0
  libequinox-osgi-java libetonyek-0.1-1 libevdocument3-4 libevview3-3 libfam0 libfbclient2 libfcgi-perl libffado2 libfile-fcntllock-perl libfluidsynth1 libfreerdp-cache1.1
  libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-plugins-standard
  libfreerdp-rail1.1 libfreerdp-utils1.1 libfreetype6 libfreetype6:i386 libgadu3 libgail18 libgbm1 libgbm1:i386 libgcc1 libgcc1:i386 libgd-perl libgd3 libgd3:i386
  libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-0:i386 libgdk-pixbuf2.0-common libgfortran3 libgimp2.0 libgirepository-1.0-1 libgksu2-0 libgl1-mesa-dev libgl1-mesa-dri
  libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles2-mesa libglib-perl libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin libgme0
  libgmpxx4ldbl libgnome2-canvas-perl libgnome2-gconf-perl libgnome2-perl libgnome2-vfs-perl libgnome2-wnck-perl libgnomecanvas2-0 libgnomecanvas2-common libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgnustep-base1.24 libgnutls-openssl27 libgomp1 libgoo-canvas-perl libgphoto2-6 libgphoto2-6:i386 libgpod-common libgpod4 libgs9
  libgs9-common libgstreamer-plugins-base1.0-0 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0 libgstreamer1.0-0:i386 libgtk-3-0 libgtk-3-bin libgtk2-imageview-perl
  libgtk2-perl libgtk2-unique-perl libgtk2.0-0 libgtk2.0-0:i386 libgtk2.0-bin libguestfs-hfsplus libguestfs-perl libguestfs-reiserfs libguestfs-tools libguestfs-xfs libguestfs0
  libharfbuzz-icu0 libhpmud0 libhsqldb-java libhsqldb1.8.0-java libhtml-parser-perl libhttrack2 libicu-dev libimage-exiftool-perl libimage-magick-perl libimage-magick-q16-perl
  libincidenceeditorsng4 libintl-perl libio-pty-perl libisoburn1 libitm1 libjack-jackd2-0 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libjfreechart-java
  libjfreechart-swt-java libjpeg-turbo-progs libjson-xs-perl libk3b6 libk3b6-extracodecs libkabc4 libkalarmcal2 libkatepartinterfaces4 libkcal4 libkcalcore4 libkcalutils4
  libkcddb4 libkcmutils4 libkdcraw23 libkde3support4 libkdeclarative5 libkdecore5 libkdepim4 libkdepimdbusinterfaces4 libkdesu5 libkdeui5 libkdewebkit5 libkdgantt2-0 libkdnssd4
  libkemoticons4 libkexiv2-11 libkfile4 libkfilemetadata4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkio5 libkjsapi4 libkjsembed4 libkldap4 libkleo4 libkmbox4
  libkmediaplayer4 libkmime4 libkmod2 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common libkonq5abi1 libkontactinterface4a libkopete4 libkparts4
  libkpgp4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4 libkresources4 libkrosscore4 libktexteditor4 libktnef4 libktorrent-l10n libktorrent5
  libkunitconversion4 libkutils4 libkxmlrpcclient4 libldap-2.4-2 libldap-2.4-2:i386 libldb1 liblircclient0 liblist-moreutils-perl liblocale-gettext-perl libloudmouth1-0 liblsan0
  liblvm2app2.2 liblvm2cmd2.02 libmagic1 libmailtransport4 libmediastreamer-base3 libmessagecomposer4 libmessagecore4 libmessageviewer4 libmicroblog4 libmm-glib0 libmodplug1
  libmodule-pluggable-perl libmono-corlib4.5-cil libmono-data-tds4.0-cil libmono-i18n-cjk4.0-cil libmono-i18n-mideast4.0-cil libmono-i18n-other4.0-cil libmono-i18n-rare4.0-cil
  libmono-i18n-west4.0-cil libmono-i18n4.0-all libmono-i18n4.0-cil libmono-posix4.0-cil libmono-security4.0-cil libmono-system-configuration4.0-cil libmono-system-core4.0-cil
  libmono-system-data4.0-cil libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil libmono-system-numerics4.0-cil libmono-system-runtime-serialization4.0-cil
  libmono-system-security4.0-cil libmono-system-transactions4.0-cil libmono-system-xml-linq4.0-cil libmono-system-xml4.0-cil libmono-system4.0-cil libmouse-perl libmspub-0.1-1
  libmwaw-0.3-3 libnautilus-extension1a libneon27-gnutls libnepomuk4 libnepomukquery4a libnepomukutils4 libnet-dbus-perl libnet-ssleay-perl libnm-glib-vpn1 libnm-glib4
  libnm-util2 libnspr4 libnss-winbind libnss3 libobjc4 libodfgen-0.1-1 libofa0 libopenal-data libopenal1 libopenal1:i386 liborbit-2-0 liborbit2 libosgi-core-java
  libpackagekit-glib2-18 libpam-systemd libpam-winbind libpango-perl libparams-util-perl libparted-fs-resize0 libparted2 libperlio-gzip-perl libpimcommon4 libpkcs11-helper1
  libplasma3 libplot2c2 libpod-readme-perl libpoppler-glib8 libpoppler-qt4-4 libppl-c4 libproc-processtable-perl libpspell-dev libpstoedit0c2a libpulse-mainloop-glib0 libpulse0
  libpulse0:i386 libpulsedsp libpurple0 libpython-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libqca2 libqca2-plugin-gnupg libqca2-plugin-ossl
  libqgpgme1 libqmi-proxy libqmobipocket1 libqt4-dbus libqt4-dbus:i386 libqt4-declarative libqt4-designer libqt4-help libqt4-network libqt4-network:i386 libqt4-opengl
  libqt4-opengl:i386 libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xml:i386
  libqt4-xmlpatterns libqt4-xmlpatterns:i386 libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5opengl5-dev libqt5printsupport5 libqt5sql5
  libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libqtassistantclient4 libqtcore4 libqtcore4:i386 libqtdbus4 libqtdbus4:i386 libqtglib-2.0-0 libqtgui4 libqtgui4:i386
  libqtruby4shared2 libqtscript4-core libqtscript4-gui libqtscript4-network libqtscript4-sql libqtscript4-uitools libqtscript4-xml libqtwebkit4 libqtwebkit4:i386 libquadmath0
  librados2 librarian0 librbd1 libreadline-dev libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-l10n-ar
  libreoffice-l10n-en-gb libreoffice-math libreoffice-report-builder-bin libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-style-galaxy libreoffice-style-oxygen
  libreoffice-writer libresid-builder0c2a librevenge-0.0-0 librpm3 librpmbuild3 librpmio3 librubberband2 libsane libsane-common libsane-hpaio libsasl2-2 libsasl2-2:i386
  libsasl2-modules libsasl2-modules:i386 libsdl-image1.2 libsdl-mixer1.2 libsdl2-2.0-0 libsendlater4 libsidplay2 libsmbclient libsmokeqtcore4-3 libsmokeqtdbus4-3
  libsmokeqtgui4-3 libsmokeqtnetwork4-3 libsmokeqtopengl4-3 libsmokeqtsql4-3 libsmokeqtsvg4-3 libsmokeqtxml4-3 libsmpeg0 libsnmp30 libsocket-perl libsocket6-perl libsolid4
  libsoprano4 libspice-server1 libssh-4 libssl-dev libstdc++6 libstdc++6:i386 libsub-identify-perl libsub-name-perl libsyndication4 libsys-virt-perl libsystemd0 libsystemd0:i386
  libtag-extras1 libtbb2 libtelepathy-qt4-2 libtemplateparser4 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtext-soundex-perl libthreadweaver4 libtomcrypt0
  libtsan0 libubsan0 libudev1 libudev1:i386 libunicode-linebreak-perl libuniconf4.6 libuuid-perl libvirt0 libvirtodbc0 libvisio-0.1-1 libvisual-0.4-plugins
  libvisual-0.4-plugins:i386 libvte-2.91-0 libvte-2.91-common libwayland-egl1-mesa libwayland-egl1-mesa:i386 libwbclient0 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwin-hivex-perl
  libwine libwine:i386 libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1 libwinpr-utils0.1 libwnck-3-0 libwpd-0.10-10 libwpg-0.3-3 libwvstreams4.6-base
  libwvstreams4.6-extras libxatracker2 libxerces-c3.1 libxfreerdp-client1.1 libxml-parser-perl libxml2 libxml2:i386 libxml2-dev libyelp0 lintian linux-headers-amd64
  linux-image-amd64 locales lp-solve lsb-release luckybackup luckybackup-data lvm2 lzma marble-plugins mariadb-client mariadb-server mediainfo menu mesa-common-dev mesa-utils
  mesa-vdpau-drivers meterbridge mktorrent mkvtoolnix modemmanager mono-4.0-gac mono-gac mono-runtime mono-runtime-common mono-runtime-sgen network-manager
  network-manager-openvpn network-manager-pptp network-manager-vpnc notification-daemon ntfs-3g ntpdate obex-data-server okular opensc opensc-pkcs11 openssh-client openssl
  openvpn p7zip p7zip-full packagekit packagekit-tools par2 partclone parted partimage partitionmanager perl perl-base perlmagick phonon-backend-gstreamer
  phonon-backend-gstreamer-common pidgin pidgin-data plasma-dataengines-addons plasma-desktop plasma-nm plasma-scriptengine-javascript plasma-widgets-addons plymouth
  plymouth-themes plymouth-x11 po4a polkit-kde-1 poppler-utils ppp print-manager printer-driver-all printer-driver-brlaser printer-driver-dymo printer-driver-hpcups
  printer-driver-hpijs printer-driver-postscript-hp printer-driver-splix procps pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf
  pulseaudio-module-zeroconf pulseaudio-utils python python-apt python-cffi python-cryptography python-dbus-dev python-gi python-gobject python-html5lib python-ldb
  python-libtorrent python-lxml python-minimal python-opencv python-openssl python-paramiko python-pexpect python-pil python-pycurl python-pyorbit python-qt4 python-qt4-dbus
  python-requests python-samba python-service-identity python-sip python-talloc python-twisted python-twisted-conch python-twisted-core python-twisted-mail python-twisted-names
  python-twisted-news python-twisted-runner python-twisted-web python-twisted-words python-urllib3 python-wxgtk3.0 python-xapian python2.7 python2.7-minimal python3
  python3-apparmor python3-apt python3-cairo python3-dbus python3-gi python3-gi-cairo python3-libapparmor python3-minimal python3-pykde4 python3-pyqt4 python3-sip
  python3-software-properties qapt-batch qdbus qemu-system-x86 qemu-utils qjackctl qpdf qt5-default qt5-qmake qtbase5-dev qtbase5-dev-tools qtchooser qtcurve qtm quassel-kde4
  rarian-compat rdesktop recordmydesktop rpm rpm-common rpm2cpio rsyslog ruby ruby-debian ruby-httpclient ruby-qt4 ruby-xmlparser sabnzbdplus samba samba-common samba-common-bin
  samba-dsdb-modules samba-libs samba-vfs-modules scdaemon shutter smbclient software-properties-common solydxk-system soprano-daemon squashfs-tools synaptic
  system-config-printer system-config-printer-udev systemd systemsettings telnet udev ufraw-batch unar unixodbc uno-libs3 unrar upower ure usb-modeswitch usb-modeswitch-data
  usbmuxd vim-common vim-tiny virtualbox virtualbox-dkms virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 virtualbox-qt virtuoso-minimal
  virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common vokoscreen vpnc w3m webhttrack wget winbind wine wine32:i386 wine64 winff-gtk2 wpasupplicant xinput-calibrator xnest
  xorriso xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-wacom
  xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware yelp zenity zenity-common
0 upgraded, 0 newly installed, 0 to remove and 1017 not upgraded.
N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension

abuyahya
Posts: 13
Joined: 30 Nov 2013 14:39

Re: Broken dependencies following upgrade

Postby abuyahya » 24 Dec 2017 14:58

I want to try and salvage this rather than fresh instal ( which I fear will have to do eventually anyway)

if i try this (taken from https://community.linuxmint.com/tutorial/view/482)

Code: Select all

sudo aptitude update && sudo aptitude install gtkorphan
initially prints this

Code: Select all

           
The following NEW packages will be installed:
  gtkorphan libc-l10n{a} libgtk2-gladexml-perl{a} libperl5.24{a} perl-modules-5.24{ab} 
The following packages will be upgraded:
  libc-bin libc6 libc6:i386 libcpan-meta-perl libsocket-perl locales perl perl-base{b} 
8 packages upgraded, 5 newly installed, 0 to remove and 1009 not upgraded.
Need to get 18.1 MB of archives. After unpacking 24.3 MB will be used.
The following packages have unmet dependencies:                                                                                                                                    
 libmouse-perl : Depends: perlapi-5.20.0 which is a virtual package.                                                                                                               
 libparams-util-perl : Depends: perlapi-5.20.0 which is a virtual package.                                                                                                         
 libimage-magick-q16-perl : Depends: perlapi-5.20.2 which is a virtual package.
 libunicode-linebreak-perl : Depends: perlapi-5.20.2 which is a virtual package.
 libpango-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libfile-fcntllock-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libnet-ssleay-perl : Depends: perlapi-5.20.2 which is a virtual package.
 perl-base : Breaks: perl-modules (< 5.24.1~) but 5.20.2-3+deb8u9 is installed.
             Breaks: perl-modules:i386 (< 5.24.1~) which is a virtual package.
 libproc-processtable-perl : Depends: perlapi-5.20.1 which is a virtual package.
 libguestfs-perl : Depends: perlapi-5.20.1 which is a virtual package.
 libgnome2-canvas-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libgtk2-unique-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libgnome2-gconf-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libcrypt-openssl-rsa-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libgnome2-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libnet-dbus-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libalgorithm-diff-xs-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libperlio-gzip-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libclass-c3-xs-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libgd-perl : Depends: perlapi-5.20.0 which is a virtual package.
 liblist-moreutils-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libsys-virt-perl : Depends: perlapi-5.20.1 which is a virtual package.
 libjson-xs-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libc-dev-bin : Depends: libc6 (< 2.20) but 2.24-11+deb9u1 is to be installed.
 perl-modules-5.24 : Conflicts: perl-modules (< 5.22.0~) but 5.20.2-3+deb8u9 is installed.
                     Conflicts: perl-modules:i386 (< 5.22.0~) which is a virtual package.
 libgnome2-wnck-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libuuid-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libwin-hivex-perl : Depends: perlapi-5.20.2 which is a virtual package.
 libgoo-canvas-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libtext-charwidth-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libperl5.20 : Depends: perl-base (= 5.20.2-3+deb8u9) but 5.24.1-3+deb9u2 is to be installed.
 libhtml-parser-perl : Depends: perlapi-5.20.1 which is a virtual package.
 libcrypt-openssl-bignum-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libterm-readkey-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libapparmor-perl : Depends: perlapi-5.20.1 which is a virtual package.
 libpurple0 : Depends: perlapi-5.20.2 which is a virtual package.
 libtext-iconv-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libgtk2-perl : Depends: perlapi-5.20.1 which is a virtual package.
 libsub-name-perl : Depends: perlapi-5.20.1 which is a virtual package.
 libglib-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libapt-pkg-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libgnome2-vfs-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libbit-vector-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libfcgi-perl : Depends: perlapi-5.20.2 which is a virtual package.
 libsub-identify-perl : Depends: perlapi-5.20.1 which is a virtual package.
 libdate-calc-xs-perl : Depends: perlapi-5.20.1 which is a virtual package.
 liblocale-gettext-perl : PreDepends: perlapi-5.20.0 which is a virtual package.
 libtext-soundex-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libsocket6-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libio-pty-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libclone-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libgtk2-imageview-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libcommon-sense-perl : Depends: perlapi-5.20.2 which is a virtual package.
                        Depends: perl (< 5.20.3~) but 5.24.1-3+deb9u2 is to be installed.
 libdbd-mysql-perl : Depends: perlapi-5.20.2 which is a virtual package.
 libxml-parser-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libc6-dev : Depends: libc6 (= 2.19-18+deb8u10) but 2.24-11+deb9u1 is to be installed.
 pidgin : Depends: perlapi-5.20.2 which is a virtual package.
 libcairo-perl : Depends: perlapi-5.20.0 which is a virtual package.
 libdbi-perl : Depends: perlapi-5.20.0 which is a virtual package.
open: 402; closed: 664; defer: 284; conflict: 325                                                                                                                                 .The following actions will resolve these dependencies:

       Remove the following packages:                                                          
1)       amarok                                                                                
2)       android-libhost-dev                                                                   
3)       apparmor                                                                              
4)       apparmor-utils                                                                        
5)       apt-file                                                                              
6)       apt-show-versions                                                                     
7)       ark                                                                                   
8)       aspell                                                                                
9)       aspell-en                                                                             
10)      bluedevil                                                                             
11)      build-essential                                                                       
12)      command-not-found                                                                     
13)      console-setup                                                                         
14)      console-setup-linux                                                                   
15)      debconf-i18n                                                                          
16)      dh-autoreconf                                                                         
17)      dictionaries-common                                                                   
18)      digikam                                                                               
19)      dolphin                                                                               
20)      enchant                                                                               
21)      fglrx-control                                                                         
22)      fglrx-driver                                                                          
23)      g++                                                                                   
24)      g++-4.4                                                                               
25)      g++-4.6                                                                               
26)      g++-4.7                                                                               
27)      g++-4.8                                                                               
28)      g++-4.9                                                                               
29)      gdebi-kde                                                                             
30)      gir1.2-webkit-3.0                                                                     
31)      gnome-user-guide                                                                      
32)      gwenview                                                                              
33)      hplip                                                                                 
34)      hplip-gui                                                                             
35)      hunspell                                                                              
36)      hunspell-ar                                                                           
37)      hunspell-en-med                                                                       
38)      icoutils                                                                              
39)      intltool                                                                              
40)      k3b                                                                                   
41)      k4dirstat                                                                             
42)      kaddressbook                                                                          
43)      kate                                                                                  
44)      kcalc                                                                                 
45)      kcharselect                                                                           
46)      kde-baseapps-bin                                                                      
47)      kde-runtime                                                                           
48)      kde-style-oxygen                                                                      
49)      kde-window-manager                                                                    
50)      kde-workspace                                                                         
51)      kde-workspace-bin                                                                     
52)      kdebase-runtime                                                                       
53)      kdeconnect                                                                            
54)      kdelibs5-plugins                                                                      
55)      kdepasswd                                                                             
56)      kdepim-runtime                                                                        
57)      kdesudo                                                                               
58)      kdf                                                                                   
59)      kdm                                                                                   
60)      keyboard-configuration                                                                
61)      kfind                                                                                 
62)      kget                                                                                  
63)      kgpg                                                                                  
64)      khelpcenter4                                                                          
65)      kinfocenter                                                                           
66)      kio-audiocd                                                                           
67)      kipi-plugins                                                                          
68)      klipper                                                                               
69)      kmenuedit                                                                             
70)      kmix                                                                                  
71)      knotes                                                                                
72)      konqueror-nsplugins                                                                   
73)      konsole                                                                               
74)      kopete                                                                                
75)      kppp                                                                                  
76)      krdc                                                                                  
77)      krusader                                                                              
78)      kscreen                                                                               
79)      kscreensaver                                                                          
80)      kscreensaver-xsavers                                                                  
81)      ksnapshot                                                                             
82)      ksysguard                                                                             
83)      ksystemlog                                                                            
84)      ktorrent                                                                              
85)      kuser                                                                                 
86)      kvkbd                                                                                 
87)      kwalletmanager                                                                        
88)      kwrite                                                                                
89)      libalgorithm-diff-xs-perl                                                             
90)      libapparmor-perl                                                                      
91)      libapt-pkg-perl                                                                       
92)      libautodie-perl                                                                       
93)      libbit-vector-perl                                                                    
94)      libbz2-dev                                                                            
95)      libc-dev-bin                                                                          
96)      libc6-dev                                                                             
97)      libcairo-perl                                                                         
98)      libcalendarsupport4                                                                   
99)      libcgi-fast-perl                                                                      
100)     libcgi-pm-perl                                                                        
101)     libclass-accessor-perl                                                                
102)     libclass-c3-xs-perl                                                                   
103)     libclone-perl                                                                         
104)     libcommon-sense-perl                                                                  
105)     libcrypt-openssl-bignum-perl                                                          
106)     libcrypt-openssl-rsa-perl                                                             
107)     libdata-optlist-perl                                                                  
108)     libdata-section-perl                                                                  
109)     libdate-calc-perl                                                                     
110)     libdate-calc-xs-perl                                                                  
111)     libdbd-mysql-perl                                                                     
112)     libdbi-perl                                                                           
113)     libdvd-pkg                                                                            
114)     libemail-valid-perl                                                                   
115)     libenchant1c2a                                                                        
116)     libfcgi-perl                                                                          
117)     libfile-fcntllock-perl                                                                
118)     libgd-perl                                                                            
119)     libglib-perl                                                                          
120)     libgnome2-canvas-perl                                                                 
121)     libgnome2-gconf-perl                                                                  
122)     libgnome2-perl                                                                        
123)     libgnome2-vfs-perl                                                                    
124)     libgnome2-wnck-perl                                                                   
125)     libgoo-canvas-perl                                                                    
126)     libgtk2-imageview-perl                                                                
127)     libgtk2-perl                                                                          
128)     libgtk2-unique-perl                                                                   
129)     libgtkspell0                                                                          
130)     libguestfs-perl                                                                       
131)     libguestfs-tools                                                                      
132)     libhpmud0                                                                             
133)     libhtml-form-perl                                                                     
134)     libhtml-format-perl                                                                   
135)     libhtml-parser-perl                                                                   
136)     libhtml-template-perl                                                                 
137)     libhtml-tree-perl                                                                     
138)     libhttp-server-simple-perl                                                            
139)     libicu-dev                                                                            
140)     libimage-magick-perl                                                                  
141)     libimage-magick-q16-perl                                                              
142)     libincidenceeditorsng4                                                                
143)     libio-pty-perl                                                                        
144)     libio-socket-inet6-perl                                                               
145)     libio-socket-ssl-perl                                                                 
146)     libipc-run-perl                                                                       
147)     libjpeg-dev                                                                           
148)     libjpeg62-turbo-dev                                                                   
149)     libjson-xs-perl                                                                       
150)     libkateinterfaces4                                                                    
151)     libkdepim4                                                                            
152)     libkdepimdbusinterfaces4                                                              
153)     libkopete4                                                                            
154)     liblist-moreutils-perl                                                                
155)     liblocale-gettext-perl                                                                
156)     liblwp-protocol-https-perl                                                            
157)     libmailcommon4                                                                        
158)     libmailimporter4                                                                      
159)     libmailtools-perl                                                                     
160)     libmessagecomposer4                                                                   
161)     libmessagecore4                                                                       
162)     libmessageviewer4                                                                     
163)     libmouse-perl                                                                         
164)     libnet-dbus-perl                                                                      
165)     libnet-dns-perl                                                                       
166)     libnet-dropbox-api-perl                                                               
167)     libnet-oauth-perl                                                                     
168)     libnet-smtp-ssl-perl                                                                  
169)     libnet-ssleay-perl                                                                    
170)     libnoteshared4                                                                        
171)     libpango-perl                                                                         
172)     libparams-util-perl                                                                   
173)     libparse-debianchangelog-perl                                                         
174)     libperl5.20                                                                           
175)     libperlio-gzip-perl                                                                   
176)     libpimcommon4                                                                         
177)     libpng12-dev                                                                          
178)     libproc-processtable-perl                                                             
179)     libpurple-bin                                                                         
180)     libpurple0                                                                            
181)     libreoffice-kde                                                                       
182)     libsane-hpaio                                                                         
183)     libsexy2                                                                              
184)     libsmokekdecore4-3                                                                    
185)     libsmokekdeui4-3                                                                      
186)     libsmokekfile3                                                                        
187)     libsmokekhtml3                                                                        
188)     libsmokekio3                                                                          
189)     libsmokeknewstuff2-3                                                                  
190)     libsmokeknewstuff3-3                                                                  
191)     libsmokekparts3                                                                       
192)     libsmokektexteditor3                                                                  
193)     libsmokekutils3                                                                       
194)     libsnmp30                                                                             
195)     libsocket6-perl                                                                       
196)     libsoftware-license-perl                                                              
197)     libssl-dev                                                                            
198)     libstdc++-4.8-dev                                                                     
199)     libstdc++-4.9-dev                                                                     
200)     libstdc++6-4.4-dev                                                                    
201)     libstdc++6-4.6-dev                                                                    
202)     libstdc++6-4.7-dev                                                                    
203)     libsub-exporter-perl                                                                  
204)     libsub-identify-perl                                                                  
205)     libsub-name-perl                                                                      
206)     libsys-virt-perl                                                                      
207)     libtemplateparser4                                                                    
208)     libterm-readkey-perl                                                                  
209)     libtext-charwidth-perl                                                                
210)     libtext-iconv-perl                                                                    
211)     libtext-soundex-perl                                                                  
212)     libtext-wrapi18n-perl                                                                 
213)     libtool                                                                               
214)     libunicode-linebreak-perl                                                             
215)     libuuid-perl                                                                          
216)     libwebkitgtk-1.0-0                                                                    
217)     libwebkitgtk-3.0-0                                                                    
218)     libwin-hivex-perl                                                                     
219)     libwww-mechanize-perl                                                                 
220)     libwww-perl                                                                           
221)     libxml-parser-perl                                                                    
222)     libxml-sax-expat-perl                                                                 
223)     libxml-simple-perl                                                                    
224)     libxml-twig-perl                                                                      
225)     libxml-xpath-perl                                                                     
226)     libyelp0                                                                              
227)     lintian                                                                               
228)     mariadb-client                                                                        
229)     mariadb-client-10.0                                                                   
230)     mariadb-server                                                                        
231)     mariadb-server-10.0                                                                   
232)     module-assistant                                                                      
233)     mplayerthumbs                                                                         
234)     myspell-en-us                                                                         
235)     okular                                                                                
236)     openra                                                                                
237)     partitionmanager                                                                      
238)     perl-modules                                                                          
239)     perlmagick                                                                            
240)     pidgin                                                                                
241)     plasma-dataengines-workspace                                                          
242)     plasma-desktop                                                                        
243)     plasma-netbook                                                                        
244)     plasma-nm                                                                             
245)     plasma-scriptengine-superkaramba                                                      
246)     plasma-widgets-addons                                                                 
247)     plasma-widgets-workspace                                                              
248)     playonlinux                                                                           
249)     polkit-kde-1                                                                          
250)     print-manager                                                                         
251)     printer-driver-hpcups                                                                 
252)     printer-driver-hpijs                                                                  
253)     printer-driver-postscript-hp                                                          
254)     python-sexy                                                                           
255)     python-webkit                                                                         
256)     python3-pykde4                                                                        
257)     qapt-batch                                                                            
258)     quassel-kde4                                                                          
259)     rootactions-servicemenu                                                               
260)     ruby-kde4                                                                             
261)     shutter                                                                               
262)     solydxk-constructor                                                                   
263)     solydxk-softwaremanager                                                               
264)     systemsettings                                                                        
265)     updatemanager                                                                         
266)     virtualbox-guest-x11                                                                  
267)     xbmc                                                                                  
268)     xbmc-bin                                                                              
269)     xbmc-data                                                                             
270)     xscreensaver                                                                          
271)     xscreensaver-data                                                                     
272)     xscreensaver-data-extra                                                               
273)     xscreensaver-screensaver-bsod                                                         
274)     xserver-xorg                                                                          
275)     xserver-xorg-core                                                                     
276)     xserver-xorg-input-all                                                                
277)     xserver-xorg-input-evdev                                                              
278)     xserver-xorg-input-mouse                                                              
279)     xserver-xorg-input-synaptics                                                          
280)     xserver-xorg-input-vmmouse                                                            
281)     xserver-xorg-input-wacom                                                              
282)     xserver-xorg-video-ati                                                                
283)     xserver-xorg-video-cirrus                                                             
284)     xserver-xorg-video-fbdev                                                              
285)     xserver-xorg-video-intel                                                              
286)     xserver-xorg-video-mach64                                                             
287)     xserver-xorg-video-mga                                                                
288)     xserver-xorg-video-modesetting                                                        
289)     xserver-xorg-video-neomagic                                                           
290)     xserver-xorg-video-openchrome                                                         
291)     xserver-xorg-video-r128                                                               
292)     xserver-xorg-video-radeon                                                             
293)     xserver-xorg-video-savage                                                             
294)     xserver-xorg-video-siliconmotion                                                      
295)     xserver-xorg-video-sisusb                                                             
296)     xserver-xorg-video-tdfx                                                               
297)     xserver-xorg-video-trident                                                            
298)     xserver-xorg-video-vesa                                                               
299)     xserver-xorg-video-vmware                                                             
300)     yelp                                                                                  
301)     zenity                                                                                
302)     zlib1g-dev                                                                            

       Keep the following packages at their current version:                                   
303)     gtkorphan [Not Installed]                                                             
304)     libgtk2-gladexml-perl [Not Installed]                                                 

       Leave the following dependencies unresolved:                                            
305)     firefox recommends myspell-en-us | hunspell-en-us                                     
306)     cryptsetup recommends console-setup                                                   
307)     debconf recommends debconf-i18n                                                       
308)     dpkg-dev recommends build-essential                                                   
309)     libdpkg-perl recommends libfile-fcntllock-perl                                        
310)     libdpkg-perl recommends liblocale-gettext-perl                                        
311)     icewm-common recommends xscreensaver                                                  
312)     libalgorithm-diff-perl recommends libalgorithm-diff-xs-perl                           
313)     libclass-c3-perl recommends libclass-c3-xs-perl                                       
314)     libdata-random-perl recommends libgd-perl                                             
315)     libhtml-tree-perl recommends libwww-perl                                              
316)     libjson-perl recommends libjson-xs-perl (>= 2.340)                                    
317)     libmodule-build-perl recommends libsoftware-license-perl (>= 0.103009)                
318)     libmro-compat-perl recommends libclass-c3-xs-perl                                     
319)     libnet-http-perl recommends libio-socket-ssl-perl                                     
320)     libltdl-dev recommends libtool                                                        
321)     libwww-mechanize-perl recommends libio-socket-ssl-perl                                
322)     libwww-perl recommends libmailtools-perl                                              
323)     libxml-sax-perl recommends libxml-sax-expat-perl                                      
324)     libxml-twig-perl recommends libtext-iconv-perl                                        
325)     libxml-twig-perl recommends libwww-perl                                               
326)     libxml-twig-perl recommends libhtml-parser-perl                                       
327)     lightdm recommends xserver-xorg                                                       
328)     lottanzb recommends yelp (>= 2.30)                                                    
329)     module-assistant recommends liblocale-gettext-perl                                    
330)     xdg-utils recommends libnet-dbus-perl                                                 
331)     xscreensaver recommends perl5                                                         
332)     steam:i386 recommends zenity:i386                                                     
333)     fglrx-atieventsd recommends fglrx-driver (= 1:15.9-4~deb8u2)                          
334)     gcc-4.4 recommends libc6-dev (>= 2.13-5)                                              
335)     ktorrent-data recommends ktorrent (>= 4.3.1-2)                                        
336)     libkhtml5 recommends kdelibs5-plugins (= 4:4.14.2-5+deb8u2)                           
337)     gcc-4.9 recommends libc6-dev (>= 2.13-5)                                              
338)     libgcc-4.8-dev recommends libc6-dev (>= 2.13-5)                                       
339)     libaspell15 recommends aspell-en | aspell-dictionary | aspell6a-dictionary            
340)     xserver-xorg-video-mga recommends xserver-xorg-video-modesetting                      
341)     amarok-common recommends amarok (>= 2.8.0-2.1)                                        
342)     gcc-4.7 recommends libc6-dev (>= 2.13-5)                                              
343)     synaptic recommends libgtk2-perl (>= 1:1.130)                                         
344)     plasma-nm recommends kwalletmanager                                                   
345)     aptitude recommends libparse-debianchangelog-perl                                     
346)     gcc recommends libc6-dev | libc-dev                                                   
347)     libkopete4 recommends kopete (= 4:4.14.1-2)                                           
348)     fglrx-source recommends module-assistant | kernel-package                             
349)     gcc-4.8 recommends libc6-dev (>= 2.13-5)                                              
350)     amarok recommends kio-audiocd                                                         
351)     libdate-calc-perl recommends libdate-calc-xs-perl                                     
352)     po4a recommends libtext-wrapi18n-perl                                                 
353)     po4a recommends libterm-readkey-perl                                                  
354)     po4a recommends liblocale-gettext-perl                                                
355)     po4a recommends libunicode-linebreak-perl                                             
356)     plasma-desktop recommends kde-workspace                                               
357)     aptdaemon recommends lintian                                                          
358)     gcc-4.6 recommends libc6-dev (>= 2.13-5)                                              
359)     libgcc-4.9-dev recommends libc6-dev (>= 2.13-5)                                       
360)     xserver-xorg-video-cirrus recommends xserver-xorg-video-modesetting                   
361)     libgcc-4.7-dev recommends libc6-dev (>= 2.13-5)                                       
362)     lintian recommends libperlio-gzip-perl                                                
363)     virtualbox-guest-utils recommends virtualbox-guest-x11 (= 4.3.36-dfsg-1+deb8u1)       
364)     libhunspell-1.3-0 recommends hunspell-en-us | hunspell-dictionary | myspell-dictionary
365)     console-tools recommends console-setup | console-data (>= 2002.12.04dbs-1)            
366)     console-tools recommends console-setup | console-common                               
367)     aspell recommends aspell-en | aspell-dictionary | aspell6a-dictionary                 
368)     shutter recommends libgoo-canvas-perl                                                 
369)     libkio5 recommends kdelibs5-plugins (= 4:4.14.2-5+deb8u2)                             
370)     digikam recommends kipi-plugins                                                       
371)     digikam recommends ffmpegthumbs | mplayerthumbs                                       
372)     libsane-hpaio recommends hplip (= 3.14.6-1+deb8u1)                                    
373)     printer-driver-all recommends printer-driver-hpcups                                   
374)     printer-driver-all recommends printer-driver-hpijs                                    
375)     printer-driver-all recommends printer-driver-postscript-hp                            


Accept this solution? [Y/n/q/?] n
if i decline that one as its removing too much in particular xserver i dont think i would have a desktop left
the second offered solution is :

Code: Select all

open: 661; closed: 2525; defer: 285; conflict: 331                                                                                                                                .The following actions will resolve these dependencies:

      Remove the following packages:                                                         
1)      apt-file                                                                             
2)      apt-show-versions                                                                    
3)      command-not-found                                                                    
4)      libapt-pkg-perl                                                                      
5)      libdbd-mysql-perl                                                                    
6)      libguestfs-perl                                                                      
7)      libguestfs-tools                                                                     
8)      libimage-magick-perl                                                                 
9)      libimage-magick-q16-perl                                                             
10)     libperl5.20                                                                          
11)     libpurple-bin                                                                        
12)     libpurple0                                                                           
13)     lintian                                                                              
14)     perl-modules                                                                         
15)     perlmagick                                                                           
16)     pidgin                                                                               
17)     shutter                                                                              
18)     solydxk-constructor                                                                  
19)     updatemanager                                                                        

      Install the following packages:                                                        
20)     libexporter-tiny-perl [0.042-1 (stable)]                                             
21)     libgnutls30 [3.5.8-5+deb9u3 (stable)]                                                
22)     libhogweed4 [3.3-1+b2 (stable)]                                                      
23)     libnettle6 [3.3-1+b2 (stable)]                                                       
24)     libssl1.0.2 [1.0.2l-2+deb9u2 (stable)]                                               
25)     libssl1.1 [1.1.0f-3+deb9u1 (stable)]                                                 
26)     libtypes-serialiser-perl [1.0-1 (stable)]                                            
27)     libxen-4.8 [4.8.2+xsa245-0+deb9u1 (stable)]                                          
28)     perl-openssl-defaults [3 (stable)]                                                   

      Upgrade the following packages:                                                        
29)     libalgorithm-diff-xs-perl [0.04-3+b1 (now) -> 0.04-4+b2 (stable)]                    
30)     libapparmor-perl [2.9.0-3 (now) -> 2.11.0-3 (stable)]                                
31)     libbit-vector-perl [7.3-1+b2 (now) -> 7.4-1+b2 (stable)]                             
32)     libc-dev-bin [2.19-18+deb8u10 (now) -> 2.24-11+deb9u1 (stable)]                      
33)     libc6-dev [2.19-18+deb8u10 (now) -> 2.24-11+deb9u1 (stable)]                         
34)     libcairo-perl [1.104-2 (now) -> 1.106-1+b2 (stable)]                                 
35)     libclass-c3-xs-perl [0.13-2+b1 (now) -> 0.14-1+b1 (stable)]                          
36)     libclone-perl [0.37-1+b1 (now) -> 0.38-2+b1 (stable)]                                
37)     libcommon-sense-perl [3.73-2+b3 (now) -> 3.74-2 (stable)]                            
38)     libcrypt-openssl-bignum-perl [0.04-4+b2 (now) -> 0.07-2 (stable)]                    
39)     libcrypt-openssl-rsa-perl [0.28-2+b1 (now) -> 0.28-5 (stable)]                       
40)     libdate-calc-perl [6.3-2 (now) -> 6.4-1 (stable)]                                    
41)     libdate-calc-xs-perl [6.3-2 (now) -> 6.4-1+b2 (stable)]                              
42)     libdbi-perl [1.631-3+b1 (now) -> 1.636-1+b1 (stable)]                                
43)     libfcgi-perl [0.77-1+deb8u1 (now) -> 0.78-2 (stable)]                                
44)     libfile-fcntllock-perl [0.22-1+b1 (now) -> 0.22-3+b2 (stable)]                       
45)     libgd-perl [2.53-1+b1 (now) -> 2.53-3 (stable)]                                      
46)     libglib-perl [3:1.305-2 (now) -> 3:1.324-1 (stable)]                                 
47)     libgnome2-canvas-perl [1.002-3+b1 (now) -> 1.002-4+b1 (stable)]                      
48)     libgnome2-gconf-perl [1.044-5+b1 (now) -> 1.044-6+b1 (stable)]                       
49)     libgnome2-perl [1.045-1+b1 (now) -> 1.046-3+b1 (stable)]                             
50)     libgnome2-vfs-perl [1.082-1+b1 (now) -> 1.082-1+b3 (stable)]                         
51)     libgnome2-wnck-perl [0.16-3+b1 (now) -> 0.16-3+b3 (stable)]                          
52)     libgoo-canvas-perl [0.06-2+b1 (now) -> 0.06-2+b3 (stable)]                           
53)     libgtk2-imageview-perl [0.05-2+b1 (now) -> 0.05-2+b3 (stable)]                       
54)     libgtk2-perl [2:1.2492-4 (now) -> 2:1.2499-1 (stable)]                               
55)     libgtk2-unique-perl [0.05-2+b1 (now) -> 0.05-2+b3 (stable)]                          
56)     libhtml-parser-perl [3.71-1+b3 (now) -> 3.72-3 (stable)]                             
57)     libio-pty-perl [1:1.08-1+b4 (now) -> 1:1.08-1.1+b2 (stable)]                         
58)     libjson-xs-perl [2.340-1+b2 (now) -> 3.030-1 (stable)]                               
59)     liblist-moreutils-perl [0.33-2+b1 (now) -> 0.416-1+b1 (stable)]                      
60)     liblocale-gettext-perl [1.05-8+b1 (now) -> 1.07-3+b1 (stable)]                       
61)     libmouse-perl [2.3.0-1+b1 (now) -> 2.4.7-1 (stable)]                                 
62)     libnet-dbus-perl [1.0.0-2+b2 (now) -> 1.1.0-4+b1 (stable)]                           
63)     libnet-ssleay-perl [1.65-1+deb8u1 (now) -> 1.80-1 (stable)]                          
64)     libpango-perl [1.226-2 (now) -> 1.227-1+b1 (stable)]                                 
65)     libparams-util-perl [1.07-2+b1 (now) -> 1.07-3+b1 (stable)]                          
66)     libperlio-gzip-perl [0.18-3+b1 (now) -> 0.19-1+b2 (stable)]                          
67)     libproc-processtable-perl [0.51-1 (now) -> 0.53-2 (stable)]                          
68)     libsnmp30 [5.7.2.1+dfsg-1 (now) -> 5.7.3+dfsg-1.7 (stable)]                          
69)     libsocket6-perl [0.25-1+b1 (now) -> 0.27-1+b1 (stable)]                              
70)     libsub-identify-perl [0.08-1 (now) -> 0.12-2+b1 (stable)]                            
71)     libsub-name-perl [0.12-1 (now) -> 0.21-1 (stable)]                                   
72)     libsys-virt-perl [1.2.9-2 (now) -> 3.0.0-1 (stable)]                                 
73)     libterm-readkey-perl [2.32-1+b1 (now) -> 2.37-1 (stable)]                            
74)     libtext-charwidth-perl [0.04-7+b3 (now) -> 0.04-7+b5 (stable)]                       
75)     libtext-iconv-perl [1.7-5+b2 (now) -> 1.7-5+b4 (stable)]                             
76)     libtext-soundex-perl [3.4-1+b2 (now) -> 3.4-1+b4 (stable)]                           
77)     libunicode-linebreak-perl [0.0.20140601-2+deb8u2 (now) -> 0.0.20160702-1+b1 (stable)]
78)     libuuid-perl [0.05-1+b1 (now) -> 0.27-1 (stable)]                                    
79)     libvirt0 [1.2.9-9+deb8u4 (now) -> 3.0.0-4+deb9u1 (stable)]                           
80)     libwin-hivex-perl [1.3.10-2+deb8u2 (now) -> 1.3.13-2+b2 (stable)]                    
81)     libxml-parser-perl [2.41-3 (now) -> 2.44-2+b1 (stable)]                              

      Leave the following dependencies unresolved:                                           
82)     xscreensaver recommends perl5                                                        
83)     mariadb-client-10.0 recommends libdbd-mysql-perl (>= 1.2202)                         
84)     aptdaemon recommends lintian                                                         


Accept this solution? [Y/n/q/?] 
Any thoughts?

User avatar
ilu
Posts: 1877
Joined: 09 Oct 2013 12:45

Re: Broken dependencies following upgrade

Postby ilu » 25 Dec 2017 15:15

Don't try to install or deinstall anything at the moment. How exactly did you upgrade? Did you use the update script from schoelje or from grizzler ? You have to remember that the scripts were prepared for a SolydXK stock install,

I don't think the LMint guide will get you anywhere in this situation but the commands might be informative.

Your proprietary video driver fglrx needed to be removed first before upgrading because it's not maintained for stretch. fglrx is definitely in the way. You could try to remove it now - but better test with simulating first (-s).

And please supply the output of inxi -Fxzr.

In the meantime backup your data :-) and mentally prepare yourself for a reinstall.

Solydk_user
Posts: 1
Joined: 11 Jan 2018 20:30

Re: Broken dependencies following upgrade

Postby Solydk_user » 11 Jan 2018 20:37

Hi everybody,

I upgraded from solydk 8 to 9 using the provided script and I have the same problem as abuyahya

I would like to save the installation, so any help would be appreciated.

the output of apt-get dist-upgrade is:

Code: Select all

sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libkf5screen-bin : Breaks: kscreen (< 4:5.8) but 1.0.2.1-1 is to be installed
 libkf5screen7 : Breaks: kscreen (< 4:5.8) but 1.0.2.1-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
the output of the inxi command is:

Code: Select all

computer@net /home/computer $ inxi -Fxzr
System:    Host: net Kernel: 3.16.0-5-amd64 x86_64 (64 bit) Desktop: KDE Plasma 4.14.2
           Distro: SolydXK                                                                              
Machine:   Device: desktop Mobo: ASRock model: FM2A75M-HD+ BIOS: American Megatrends v: P1.50 date: 11/20/2013                                                                                                  
CPU:       Quad core AMD Athlon X4 750K (-MCP-) cache: 8192 KB                                          
           clock speeds: max: 3400 MHz 1: 3400 MHz 2: 1400 MHz 3: 1400 MHz 4: 3400 MHz                  
Graphics:  Card: NVIDIA GK208 [GeForce GT 630 Rev. 2]                                                   
           Display Server: X.Org 1.16.4 driver: nvidia Resolution: 1920x1080@59.93hz                    
           GLX Renderer: GeForce GT 630/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 340.102                     
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel              
           Card-2 NVIDIA GK208 HDMI/DP Audio Controller driver: snd_hda_intel                           
           Sound: Advanced Linux Sound Architecture v: k3.16.0-5-amd64                                  
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169      
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: bc:5f:f4:f4:55:1c                      
           Card-2: Qualcomm Atheros AR9227 Wireless Network Adapter driver: ath9k                       
           IF: wlan0 state: down mac: 10:fe:ed:f0:aa:ce                                                 
Drives:    HDD Total Size: 6001.2GB (58.5% used)                                                        
           ID-1: /dev/sda model: ST3000DM001 size: 3000.6GB                                             
           ID-2: USB /dev/sdb model: S2_Portable size: 1000.2GB                                         
           ID-3: USB /dev/sdg model: Elements_1048 size: 2000.4GB                                       
Partition: ID-1: / size: 96G used: 9.0G (10%) fs: ext4 dev: /dev/sda6                                   
           ID-2: /home size: 58G used: 50G (91%) fs: ext4 dev: /dev/sda7                                
           ID-3: swap-1 size: 16.78GB used: 0.00GB (0%) fs: swap dev: /dev/sda2                         
Sensors:   System Temperatures: cpu: 11.5C mobo: N/A gpu: 34C                                           
           Fan Speeds (in rpm): cpu: N/A                                                                
Info:      Processes: 215 Uptime: 31 min Memory: 2661.2/7862.1MB Client: Shell (bash) inxi: 2.3.5       
 


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 2 guests